User defined input file

Hi,

I have probably very basic question, yet I am not able to find solution how to solve the problem.

I wrote RECAST tests with a test data that are stored locally on my PC (I am using option -data and then referring to them as {readdir0}). However, I would like to run the whole workflow with the same file (which is a .json file) that is defined in init stage of my workflow. So I have a two questions:

  1. How can I refer to the file which is stored locally on my PC (not inside Docker image) from the workflow? I managed to refer to the file using a test data while testing the step standalone but I am not able to do it while running a whole workflow. My recast.yml file is here: Sign in to CERN . The thing, I am doing in test called merge, works. When I am trying to do the same in init stage, the file on my local PC is not accessed.

  2. I want to use .json file and I want to put it on eos such that CI runners have it available. Docker image of this step does not have ‘xrdcp’ because I cannot source release in it (it is image of Histfitter: Sign in to CERN ). How can I access this .json file that is stored on eos?

For a bit more context. This .json file is a file with weights for signal re-weighting. For the signal of the original analysis, this file can be even included in the Docker image but there has to be way of providing another file in case the user wants to run with a new signal files (for example for the reinterpretation).

Hi @otheiner,

  1. Please see the instructions in the using local data section of the RECAST docs for providing local input files to the recast workflow.

  2. From a quick test, it looks like the Dockerfile provided by Matthew in this post for adding xrootd to the trexfitter image should work equivalently for the histfitter image, by replacing the line FROM gitlab-registry.cern.ch/trexstats/trexfitter:latest at the top with FROM gitlab-registry.cern.ch/multibjets/mbj_histfitter:latest.

Cheers,
Danika